Anggota : 485
Posting : 815
dukerainz - Peringkat: Warga Ngoceh
Nama
harakiri
Kirim Pesan
lesperinggo - Peringkat: Warga Ngoceh
Nama
Junior
Kirim Pesan
desainplus - Peringkat: Warga Ngoceh
Nama
Dwi Setiawan
Kirim Pesan
ben_joe - Peringkat: Warga Ngoceh
Nama
ben joe
Kirim Pesan

Selamat Datang di Forum Ngoceh.us

User Manual : Cara Posting (Download versi PDF)
yoitio
Lurah Ngoceh

UserID : 684
Total Posting : 270
Tgl Gabung :
Kamis, 08 Sep 2011
Kota : Cilacap (luar kota)
Kirim Pesan
Laporkan Anggota

Cara Membuat Schedule block website dengan mikrotik

 Rabu, 15 Apr 2015 - Pukul 08:04
0 Rating:

Schedule block website dengan mikrotik

 

Kali ini saya akan share tentang block website ter schedule menggunakan mikrotik,

sedikit penjelasan kali ini skenario nya adalah saya ingin memblock facebook pada jam 8pagi – jam 5sore. saya menggunakan facebook sebagai contoh karena untuk memblock facebook tidak dapat di block hanya dengan firewall biasa tapi menggunakan layer7 protocol untuk memblock https facebook.

ether 2(internet) 192.168.100.2/24 – gateway 192.168.100.1
ether 3(local) 192.168.1.1/24

Setting ip address :

[admin@MikroTik] > ip address add address=192.168.100.2/24 interface=ether2
[admin@MikroTik] > ip address add address=192.168.1.1/24 interface=ether3

Konfigurasi gateway

[admin@MikroTik] > ip route add gateway=192.168.100.1

Setelah mengkonfigurasi gateway set dns server ,saya menggunakan dns google silahkan sesuaikan dengan dns ISP anda masing2

[admin@MikroTik] > ip dns set servers=8.8.8.8 allow-remote-requests=yes

Konfigurasi NAT(Network Address Translation)

[admin@MikroTik] > ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

Untuk membuat Schedule di perlukan NTP(Network Time Protocol) saya gunakan ntp milik LIPIntp.kim.lipi.go.id (203.160.128.6) ,Untuk set waktu berdasarkan daerah kita,saya menggunakan Asia/Jakarta.

[admin@MikroTik] > system ntp client set primary-ntp=203.160.128.6 enabled=yes mode=unicas

[admin@MikroTik] > system clock set time-zone-name=Asia/Jakarta

Agar Client kita tidak perlu set ip manual kita buat konfigurasi dhcp server

[admin@MikroTik] > ip dhcp-server setup
Select interface to run DHCP server on

dhcp server interface: ether3
Select network for DHCP addresses

dhcp address space: 192.168.1.0/24
Select gateway for given network

gateway for dhcp network: 192.168.1.1
Select pool of ip addresses given out by DHCP server

addresses to give out: 192.168.1.2-192.168.1.254
Select DNS servers

dns servers: 8.8.8.8
Select lease time

lease time: 00:30:00

Buat Konfigurasi Firewall untuk block http facebook

[admin@MikroTik] > ip firewall filter add chain=forward content=facebook action=drop protocol=tcp comment=block-fb-http

Untuk Block https facebook,gunakan layer7 protocol

[admin@MikroTik] > ip firewall layer7-protocol add name=facebook regexp=facebook

[admin@MikroTik] > ip firewall filter add chain=forward comment=block-fb-https layer7-protocol=facebook dst-port=443 protocol=tcp action=drop

Buat Script untuk mengijinkan https  dan http facebook

[admin@MikroTik] > system script add name=”fb-allow-https” policy=write,read,policy,test,sniff source={/ip firewall filter set disabled=yes [/ip firewall filter find content=”block-fb-https”]}
[admin@MikroTik] >> system script add name=”fb-allow-http” policy=write,read,policy,test,sniff source={/ip firewall filter set disabled=yes [/ip firewall filter find conent=”block-fb-http”]}

Script untuk Block https dan http facebook

[admin@MikroTik] >> system script add name=”fb-deny-http” policy=write,read,policy,test,sniff source={/ip firewall filter set disabled=no [/ip firewall filter find content=”block-fb-http”]}
[admin@MikroTik] >> system script add name=”fb-deny-https” policy=write,read,policy,test,sniff source={/ip firewall filter set disabled=no [/ip firewall filter find content=”block-fb-https”]}

Buat schedule untuk tidak mengijikan mengakses facebook pagi hari jam 8

[admin@MikroTik] >> system scheduler add name=fb-http-deny start-time=08:00:00 start-date=jul/07/2013 interval=1d on-event=fb-deny-http
[admin@MikroTik] >> system scheduler add name=fb-https-deny start-time=08:00:00 start-date=jul/07/2013 interval=1d on-event=fb-deny-https

Schedule untuk mengijinkan facebook di atas jam 5 sore

[admin@MikroTik] >> system scheduler add name=fb-https-allow start-time=17:00:00 start-date=jul/07/2013 interval=1d on-event=fb-allow-https
[admin@MikroTik] >> system scheduler add name=fb-http-allow start-time=17:00:00 start-date=jul/07/2013 interval=1d on-event=fb-allow-http

Sesuaikan schedule dan firewall rules sesuai dengan kebutuhan anda.

Semoga bisa bermanfaat.

 

sumber : yohanez00.wordpress.com

 

CARA KE 2

 

Memblokir Suatu Situs Pada Jam Tertentu

 

Berikut ini adalah suatu trik untuk memblok situs yang di atur sesuai jam. Salah satu contoh adalah situs facebook yang beberapa kantor ingin di blok pada jam kerja.


Pertama, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL: ntp.kim.lipi.go.id (203.160.128.6) dan NTP Pool Project dengan salah satu URLnya: 0.id.pool.ntp.org (202.169.224.16). Untuk mensettingnya di MikroTik, ketikkan perintah berikut :

/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes

Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content="facebook" action=drop comment="Blokir Akses Facebook";

Via Winbox : 


Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :

Script untuk mematikan (disable) firewall :

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes

Via Winbox : 

Script untuk mengaktifkan (enable) firewall :

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

Via Winbox :

Script untuk disable firewall di hari libur dan enable di hari kerja :

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}

Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya :

Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :

/system scheduler add name="fb-08:00" start-date=jan/01/2010 start-time=08:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall pada jam istirahat (12:00) :

/system scheduler add name="fb-12:00" start-date=jan/01/2010 start-time=11:30:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mengaktifkan kembali (enable) firewall pada jam kerja (13:00) :

/system scheduler add name="fb-13:00" start-date=jan/01/2010 start-time=13:00:00 interval=1d on-event="fb-deny"

Via Winbox :

Schedule untuk mematikan (disable) firewall di luar jam kerja ke atas ( > 17:00) :

/system scheduler add name="fb-16:00" start-date=jan/01/2010 start-time=16:00:00 interval=1d on-event="fb-allow"

Via Winbox :

Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :

/system scheduler add name="fb-sabtu-minggu" start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Sabtu. Dan parameter "interval" diberi nilai 7d.

Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :

/system scheduler add name="fb-senin" start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Pastikan bahwa tanggal yang didefinisikan pada parameter "start-date" scheduler adalah Hari Senin. Dan parameter "interval" diberi nilai 7d.
sumber : dimas-ehm.blogspot.com

Halaman : 1